Kirjautuminen

Haku

Tehtävät

Keskustelu: Nettisivujen teko: Guzzlehttp kirjaston asennus "käsin"

Sivu 1 / 1

pistemies [12.09.2019 09:27:00]

Lainaa #

Moi

Koska minulla on käytössä Windows 10, yritän asentaa Guzzlehttp kirjaston version 6.3.3 ilman composeria.
Tähän saakka kaikki puuttuviksi herjatut palikat olen saanut koottua oikeisiin hakemsitoihin.
Nyt törmäsin kuitenkin tähän tiedostossa Psr7/Uri.php:

use Psr\Http\Message\UriInterface;

Hakemistossa 'vendor' on tuo hakemisto 'psr', joten oletan, että kyseiset tiedostot pitäisi ladata polkuun 'vendor/psr/http/message/', mutta edelleenkin ilmoittaa saman virheen:

Interface 'Psr\Http\Message\UriInterface' not found ....... Psr7/Uri.php on line 16

Onko mahdollista, että täällä olisi joku, jonka koneelta löytyisi tämä Guzzlehttp 6.3.3 ja vilkaisisi, mikä tässä tapauksessa on sen käyttämä hakemistorakenne?

Älkääkä kyselkö, miksi en asenna koneelleni tämän takia Ubuntua :)

Metabolix [12.09.2019 16:51:38]

Lainaa #

pistemies kirjoitti:

Koska minulla on käytössä Windows 10, yritän asentaa Guzzlehttp kirjaston version 6.3.3 ilman composeria.

En ihan ymmärrä tätä logiikkaa, kun Composer on myös Windowsille saatavilla.

pistemies [12.09.2019 17:33:48]

Lainaa #

Metabolix kirjoitti:

pistemies kirjoitti:

Koska minulla on käytössä Windows 10, yritän asentaa Guzzlehttp kirjaston version 6.3.3 ilman composeria.

En ihan ymmärrä tätä logiikkaa, kun Composer on myös Windowsille saatavilla.

Ei toimi ainakaan minun Windowsissa kyseinen Compuser.

pistemies [13.09.2019 09:37:23]

Lainaa #

pistemies kirjoitti:

(12.09.2019 17:33:48): ”– –” Ei toimi ainakaan minun Windowsissa kyseinen...

No niin. Nyt löytyi "aukko" ulospääsyyn tästä ongelmasta. Composer vaati php.exe tiedoston lataamista.

pistemies [13.09.2019 13:06:42]

Lainaa #

Jotakin tämä composer-setup.exe pilasi minun tietokoneella. Mamp-palvelimen käynnitys ei toimi, ei löydä mitään dll-tiedostoja. Samoin kun antaa komennon composer install, ilmoittaa että curl-laajennusta ei löydy.
En tiedä, toimisiko tässä tapauksessa paremmin pelkän perus-apache paketin asennus ilman Mamp-kokoonpanoa.

Ps. Mamp nyt käynnistyi, kun vaihdoin PHP versioon 7.2.1. Composer herjaa yhä curlia ;)

Ps. Nyt sekin puute korjatui muokkaamalla php.inä. Guzzlehttp 6.3 lataus onnistui!!

Vastaus

Muista lukea kirjoitusohjeet.
Tietoa sivustosta