Kirjautuminen

Haku

Tehtävät

Keskustelu: Nettisivujen teko: SSL ja kuvat katoavat

Sivut:

Sivu 2 / 2

Sivun loppuun

Lebe80 [28.09.2018 13:55:36]

Lainaa #

Siis muutat vain käsin kuvien ja tiedostojen urlin perään esimerkiksi:

<script src="mun-oma-javascript.js?2019-09-28"></script>
<img src="kettu.jpg?2019-09-28" />

Tunturisusi [28.09.2018 14:13:35]

Lainaa #

Kiitokset, testaan joidenkin kuvien kanssa tätä. Noin muuten, kaikkien kuvien yhteyteen on mahdottomuus lisäillä, sivuillani on ehkä 15 - 20 tuhatta kuvaa, en tiedä tarkkaa määrää mutta niitä on paljon.

Grez [28.09.2018 14:48:19]

Lainaa #

Eihän se nyt todellisuudessa mitenkään mahdotonta ole. Käsin tehden toki työlästä, ohjelmoiden tai työkaluohjelmia käyttäen osaavalle helpohko alle tunnin projekti.

Toisaalta itsekään en lähtisi niitä kaikkia kuvia säätämään - en sillä että se olisi mahdotonta vaan koska se on käytännössä hyödytöntä. (Siis kiertää ainoastaan jotain ongelmaa joka on jossain sinun ja palvelimen välillä oleva cacheen tarttuneet rikkinäiset kuvat, joka ei sivuston muita käyttäjiä haittaa ja joka korjaantuu itsestään ajan kanssa)

Tunturisusi [28.09.2018 15:07:51]

Lainaa #

Kiitokset noista lohduttavista sanoista että tilanne korjaantuu ajan kanssa. En ole nyt muutamaan päivään käyttänyt ollenkaan Google Chromea, koska se on rasittavaa - hyviähän nämä kaksi muutakin ovat. Nimitin tätä toista Internet Exploreriksi, mutta tämä näyttää olleen vuodesta 2015 saakka Microsoft Edge.

Tunturisusi [02.10.2018 14:14:30]

Lainaa #

Löysin hienon ja toimivan ratkaisun, joka sopii toistaiseksi täydellisesti, kunnes ajat paranevat. Netistä löytyi koodi .htaccessiin, jolla kaikille sivuille tullaan ilman SSL- turvalukkoa ja koodi on tällainen:

# Redirect HTTPS to HTTP
RewriteCond %{HTTP:X-Forwarded-Proto} =https
RewriteRule ^(.*)$ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Minä kysyin juuri tällaista koodia palvelimelta, mutta he eivät siihen kysymykseeni vastanneet laisinkaan. Ei kai tästä mitään haittaa voi olla? Sivuillani ei ole minkäänlaista dialogia eikä mitään muutakaan toimintaa surffaajien kanssa, joten he ymmärtääkseni ovat täysin turvassa ilman lukkojakin.

Onko kommentteja tähän?

Toki olisin halunnut pitää sivuillani tuon vihreän lukon, mutta toistaiseksi se ei ole mahdollista.

Lisäys: Lisäys: Sitä paitsi, sivujen aukeaminen nopeutui dramaattisesti. Lukolla sivulla näkyi ensimmäiset kymmenen sekuntia valkoista, nyt latautuu solahtamalla.

The Alchemist [02.10.2018 18:08:45]

Lainaa #

Pitäisiköhän sun poistaa ne virukset koneeltasi ennen kuin väännät koko servun solmuun sekoilemalla.

Tunturisusi [02.10.2018 19:47:46]

Lainaa #

Ei minulla ole minkäänlaisia viruksia koneellani, sanoo Avg. Enkä pitäisi sekoiluna sitä, jos sivuillani ei ole turvalukkoa, ei sitä ollut ennen viimeistä paria kuukautta 18 vuoteenkaan.

Lukaise Alkemisti netin foorumeilta, kuvien näkymättömyys Google Chromella on hyvin yleinen ongelma.

Lebe80 [03.10.2018 10:31:11]

Lainaa #

Tunturisusi kirjoitti:

Lukaise Alkemisti netin foorumeilta, kuvien näkymättömyys Google Chromella on hyvin yleinen ongelma.

Itse en ole ainakaan vielä törmännyt tähän urallani.

The Alchemist [03.10.2018 11:07:57]

Lainaa #

Tunturisusi kirjoitti:

Ei minulla ole minkäänlaisia viruksia koneellani, sanoo Avg. Enkä pitäisi sekoiluna sitä, jos sivuillani ei ole turvalukkoa, ei sitä ollut ennen viimeistä paria kuukautta 18 vuoteenkaan.

Sekoilua on mm. se, että ensin laitat sivustollesi https-yhteyden ja sen jälkeen päätätkin ohjata käyttäjät POIS https:stä käyttämään salaamatonta yhteyttä. Älä konffaa https-yhteyttä alun alkaenkaan, ota kaikki sellaiset viritelmät pois.

Tunturisusi kirjoitti:

Lukaise Alkemisti netin foorumeilta, kuvien näkymättömyys Google Chromella on hyvin yleinen ongelma.

Eikä ole. Chrome lataa kuvasi aina kun oma koneesi vain on kunnossa. Ainoa "ongelmatilanne" on se, jos sivustosi käyttää https-yhteyttä mutta sivuille linkatut "assetit" eli kuva- tai tyylitiedostot tai javascriptit eivät. Se ei ole selaimen vika, se on sinun vikasi (koodarina). Jos kuvat eivät muutenkaan lataudu, niin silloin vika on sinun koneessasi.

Suomessa ei ole enää pitkään aikaan ollut käytössä sellaisia välityspalvelimia, jotka kakuttaisivat esimerkiksi kuvatiedostoja sivuston oman palvelimen ohi, joten vika ei yksinkertaisesti voi olla sinun nettiliittymässäsi tai operaattorissa vaan vika on sinun koneessasi tai vähintään käyttämässäsi modeemilaitteessa.

Tunturisusi kirjoitti:

Lisäys: Lisäys: Sitä paitsi, sivujen aukeaminen nopeutui dramaattisesti. Lukolla sivulla näkyi ensimmäiset kymmenen sekuntia valkoista, nyt latautuu solahtamalla.

Tämä vain todistaa sen, että olet vetänyt koneesi ja/tai modeemisi aivan solmuun. Valkoinen sivu johtuu siitä, ettei selain ole saanut ladattua kaikkia tarvitsemiaan assetteja ja siksi ei renderöi sivua ollenkaan. Eli koneesi yrittää hakea jotain tiettyjä (js-)tiedostoa ja kyseisen tiedoston lataaminen jää hannaamaan.

Vika on luonnollisesti koneessasi eikä nettiyhteydessä, koska sama tiedosto vaikuttaa latautuvan normaalisti salaamattoman yhteyden ylitse.

noutti [15.10.2018 21:00:49]

Lainaa #

No jaa Alchemist. Itselläni on edelleen vuodenkin jälkeen ongelmana eräässä projektissa se, että chrome ei mobiilillani siisti lataamaan yhtä kuvaa. Kaikilla muilla laitteilla kyllä, mutta tällä laitteella ei :D

Tunturisusi [15.04.2019 17:28:43]

Lainaa #

Alchemist kirjoitti:

Tämä vain todistaa sen, että olet vetänyt koneesi ja/tai modeemisi aivan solmuun. Valkoinen sivu johtuu siitä, ettei selain ole saanut ladattua kaikkia tarvitsemiaan assetteja ja siksi ei renderöi sivua ollenkaan. Eli koneesi yrittää hakea jotain tiettyjä (js-)tiedostoa ja kyseisen tiedoston lataaminen jää hannaamaan.

Vika on luonnollisesti koneessasi eikä nettiyhteydessä, koska sama tiedosto vaikuttaa latautuvan normaalisti salaamattoman yhteyden ylitse.

Laitoin tänään uudelleen tuon SSL-koodin palvelimelle ja nyt sivut avautuvat nopeasti ja kaikki kuvat lataantuvat. Sama tietokone, samat palvelun tarjoajat - ei siis ollut laisinkaan "vedetty konetta aivan solmuun".

Tuolla edellä kuitenkin joku ihan oikeinkin totesi, että "ongelma korjautuu ajan kanssa". Näin kävikin.

Odotin siten runsaat puoli vuotta, koska edellinen tilanne oli turhauttava. Miksi ei toiminut tuolloin, jää minulle mysteeriksi. Oma "arvioni" on, että ongelma oli palvelimella, vaikka he eivät sitä suostuneet myöntämään. Sivuni siirrettiin viikko sitten samalla palvelun tarjoajalla eri palvelimelle.


Sivun alkuun

Sivut:

Vastaus

Muista lukea kirjoitusohjeet.
Tietoa sivustosta